Elevated Notification Errors

Incident Report for PayGround

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 20:29 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 30, 2026 - 18:35 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 30, 2026 - 18:06 UTC

Monitoring

The service has been restored and we are monitoring.
Posted Apr 30, 2026 - 18:05 UTC

Investigating

We're experiencing an elevated level of API errors related to invoice and receipt notifications and are currently looking into the issue.
Posted Apr 30, 2026 - 17:05 UTC
This incident affected: Integrations (Messaging & Communications Integrations).